Solucionar el problema “Google Play Services no es compatible con otras aplicaciones que utilizan el mismo ID de usuario compartido”

El mundo de las ROMs personalizadas es francamente maravilloso y gracias a ellas podemos conocer y disfrutar de muchas características que a veces parecieran ocultas en el firmware un tanto limitado que nos traen nuestros dispositivos (sin dejar de lado todo el bloatware que llega por defecto).

Claro que a veces al cambiar de ROM y dejar de utilizar la oficial también ocurre en algunos inconvenientes y uno muy conocido es el qué nos informa qué “Google Play Services no es compatible con otras aplicaciones que usan el mismo id de usuario compartido”, y con ello nos vemos imposibilitados de iniciar sesión en algunos servicios de Google, como el nuevo Hangouts y YouTube (aunque en este último si podemos utilizar la aplicación).

youtube android

Vamos a ver entonces cómo solucionar este inconveniente con Google Play Services, algo que nos tomará unos pocos pasos y luego de ello estaremos en condiciones de actualizar todas las aplicaciones de la forma habitual, desde Play Store. La única recomendación a tener en cuenta que la de guardar todas nuestras configuraciones (algo que podemos hacer con Titanium Backup) puesto que vamos a eliminar los datos del teléfono.

En primer lugar debemos descargar las gapps, el pack de aplicaciones de Google compilado por los desarrolladores de CyanogenMod, prestando especial atención en hacerlo con la versión correspondiente a Gingerbread (hay una versión para Ice Cream Sandwich aunque no he probado el procedimiento en este caso).

Ubicamos el archivo zip en la memoria interna del teléfono y lo reiniciamos en modo recovery, tras lo cual seleccionamos la opción de install zip from sdcard y luego la de choose zip from sdcard. Nos posicionamos en la opción de la gapps y la seleccionamos presionando la tecla de encendido: la instalación es rápida y luego debemos volver a la pantalla inicial del recovery y desde allí dirigirnos a las opciones de wipe data, wipe cache y wipe dalvik.

Reiniciamos el teléfono y lo primero que vamos a notar que es que el proceso tarda un poco más, pero no hay que desesperar ya que esto es habitual cuando hacemos los wipes o instalamos una ROM. Luego al iniciar el sistema debemos volver a configurar la cuenta de Google y dejar que se sincronicen los contactos y demás, y cuando eso haya finalizado podemos hacer tap en el icono de Play Store o Android Market (ya que puede que las gapps hayan venido con este último). Tenemos que actualizar la aplicación de YouTube o la de Hangouts, y al querer iniciarlas se nos solicitará la instalación de Google Play Services: confirmamos esto y así finalizaremos el proceso.

Enlace: gapps

  • José Luis Díaz Alcalde

    Me parece formidable que exista solución aunque la verdad no la entiendo. Voy a buscar que me ayuden los expertos. Ah, quería preguntar si esto solucionará el problema de google+ que tampoco me funciona. Gracias desde ya por la respuesta.

    • Hola José Luis:

      Efectivamente, esta solución termina con el problema de YouTube, Google+ o los Hangouts, que requieren de la instalación de Google Play Services.

      Saludos!

  • Alexander James

    ¿Que gapps tengo que descargar? Esque no sé cual de todas :s

  • hans fuenzalida

    hola soy de chile i tengo un celular avvio 790 i me pasa ese problema que devo hacer no tengo el celular root se puede hacer eso o no o tendria que rotiarlo espero su respuesta a la brevedad por favor

    • Hola Hans, gracias por comentar

      Para realizar esto en cualquier modelo, es necesario tener el celular desbloqueado y con acceso root.

      Saludos!

  • Angel

    ¿Cual Gapps tengo que descargar? Saludos

  • bahiron

    que gapps tengo ue descargar

  • Juanma

    Hola, me gustaria saber que gapps tengo que descargar. el telefono es un xiaomi m1
    Gracias!

    • Hola Juanma! El paquete de Gapps no depende del teléfono sino de la ROM que instales (basada en ICS, en Jelly Bean, en KitKat) etc.

      Saludos!

  • Thomson

    Si tengo una rom basada en KitKat, tengo que bajar los gapps para Kitkat o para la rom que traía por defecto?

  • Duvan

    Mi hermano el paquete de gapps q necesito para kitkat no esta disponible. Otro lugar donde se puedan descargar ?? Saludos.

  • ScreamoDalton

    Mil gracias su metodo me funciono exelnte

  • Antonio

    Esos gapps son compatibles con el huawei 520? Tiene una versión 4.1.2 de androide versión china.

  • Nazareno Denis

    Buenas! Mi problema es el mismo tengo una tablet eurocase android 4.1.1 y me sale exactamente lo mismo, voy a intentar hacer esto, con ayuda nose mucho de android, pero no soy root, busque y me digieron que tenia que rootearlo! Ahora lo que me preocupa es que no sea robot pata siempre, otra cosa las cosas que mandan descargar son del google play o son de internet?

  • dfammian

    hola . tengo el mismo problema
    a q te refieres con root y q es eso
    espero pronta respuesta
    gracias

  • Bryan

    Hola. Ya tengo mi backup lista ahora falta empezar a resolver el problema pero no se gapps usar tengo un galaxy y y le cambie la rom a jellyblast 3.0.3 ¿que gapps uso? jb?

  • Wisander De Los Santos

    hola quisiera saber como yo se cual es que debo descargar de todos lo que me aparecen tengo una tablet ib modelo IB1000A android 4.2

  • Marlonis Dávila Pérez

    Hola quisiera saber que gapps .zip descargo mi celular es un huawei Y300… Gracias

  • Mateo Osorio Garcia

    gracias……….
    estaba mas asustado. se me habían dañado todo las google apps